Лабораторная работа №7




Скачать 336.4 Kb.
НазваниеЛабораторная работа №7
страница1/2
Дата конвертации13.11.2013
Размер336.4 Kb.
ТипОбзор
  1   2

    Красноярский государственный университет цветных металлов и золота

    Кафедра автоматизации производственных процессов




ЦМ





Дисциплина Применение ЭВМ в СУ

Красноярск 2005 г.



Лабораторная работа № 7

“Изучение приложения SISO Design Tool пакета Control system системы MATLAB для моделирования, имитирования и анализа систем управления с контуром обратной связи“

ЦЕЛЬ РАБОТЫ

1. Ознакомиться с составом и назначением программного приложения SISO Design Tool.

2. Ознакомиться с основными методами и примерами использования программного приложения SISO Design Tool для моделирования и анализа систем управления.

3. Освоить расчет, настройку и анализ САР в среде SISO Design Tool системы MATLAB.

МЕТОДИКА ВЫПОЛНЕНИЯ РАБОТЫ

  1. Открыть рабочее окно программы SISO Design Tool.

  2. Изучить теоретические сведения о приложении SISO Design Tool.

  3. Закончив изучение теоретических сведений о приложении SISO Design Tool, выполнить задание по моделированию СУ.

Обзор

SISO Design Tool представляет собой графический интерфейс пользователя, который позволяет анализировать и настраивать SISO системы управления с обратной связью. С помощью SISO Design Tool можно графически настраивать коэффициенты усиления и динамические свойства (dynamics) компенсатора (C) и предфильтра (F), используя комбинацию метода расположения корней и метода формирования контура.

Например, можно использовать график расположения корней, чтобы стабилизировать контур обратной связи и усилить минимальное затухание, а диаграммы Боде использовать для коррекции полосы пропускания, определения запасов устойчивости по амплитуде и фазе или добавления режекторного фильтра для подавления помех. Также можно вызвать графики Никольса для разомкнутого контура или диаграммы Боде предфильтра (F), выбрав соответствующие пункты меню View. Все графики динамически связаны между собой. Например, если изменить коэффициент усиления на графике расположения корней, то диаграмма Боде также сразу измениться.


Панель текущего компенсатора

Расположение

корней

Структура обратной связи

Диаграмма Боде разомкнутого контура

Панель статуса


Рисунок 1 Основное окно SISO Tool

SISO Design Tool разработан для работы с LTI Viewer, позволяя вносить изменения в схему и тут же отслеживать их результат в LTI Viewer. Например, если изменить параметры компенсатора, то LTI Viewer, связанный с SISO Design Tool, автоматически обновит выбранные вами графики. По умолчанию SISO Design Tool выводит на экран график расположения корней и диаграмму Боде разомкнутого контура системы.

Импортированные системы могут включать любые элементы схемы структуры с обратной связью, расположенной в правом углу панели текущего компенсатора. Нельзя изменить импортированные модели объекта управления (G) и датчика (H), но можно использовать SISO Design Tool для разработки нового (или изменения существующего) предфильтра (F) или компенсатора (С) для импортированных объекта управления и датчика.

1 Структура с обратной связью

В SISO Design Tool по умолчанию компенсатор находится в прямой цепи, т.е структура с обратной связью выглядит следующим образом:



Рисунок 2 Структура обратной связи по умолчанию

На этом рисунке приняты следующие обозначения:

  • G – объект управления;

  • H – датчик;

  • F – предфильтр;

  • С – компенсатор.

По умолчанию все значения для блоков F, H и С равны 1. В качестве объекта управления (G) задана модель двигателя переменного тока sys_dc.

2 Альтернативные структуры обратной связи

Структуру обратной связи можно изменить, нажав кнопку FS, которая циклически вызывает различные конфигурации системы. На следующем рисунке приведены различные, предусмотренные в SISO Design Tool, структуры обратной связи.



а) компенсатор в цепи обратной связи



б) Контроле с предварением



в) каскадная система с фильтром (F) во внутреннем контуре

Рисунок 3 Структуры систем с обратной связью

3 Импорт и экспорт моделей

SISO Design Tool использует графический интерфейс пользователя, чтобы упростить экспорт и импорт моделей.

Импорт моделей

Чтобы импортировать модель в SISO Design Tool, выберите в меню File пункт Import. Откроется окно Import System Data.



Рисунок 4 Окно импорта модели

Чтобы импортировать модель:

  • Определите, хотите ли вы импортировать SISO модель из рабочего пространства MATLAB, МАТ-файла или модели Simulink. В окне SISO Models появится список всех доступных моделей для каждого формата.

  • Выберите из списка необходимую модель.

  • Нажмите стрелку справа, чтобы определить хотите ли вы импортировать модель как объект управления (G), датчик (Н), предфильтр (F) или компенсатор (С).

  • Нажмите кнопку OK.

Экспорт моделей

Чтобы открыть окно SISO Tool Export выберите в меню File пункт Export.



Рисунок 5 Окно Экспорта моделей

Выбор моделей для экспорта

Окно SISO Tool Export содержит список не только всех блоков текущей модели, но и различные передаточные функции, связанные со стандартными методами анализа систем управления. Они включают передаточные функции разомкнутого и замкнутого контуров, входную и выходную функции чувствительности и модель пространства состояний всего контура обратной связи.

Чтобы выбрать модель для экспорта, щелкните правой кнопкой мыши по строке, содержащей имя компонента. Чтобы изменить имя экспортируемого блока, дважды щелкните мышкой по ячейке столбца Export As, содержащей компонент.

Можно экспортировать модель либо в рабочее пространство MATLAB либо на диск. В последнем случае модель будет сохранена как МАТ-файл.

Экспорт в рабочее пространство

Чтобы экспортировать модель в рабочее пространство MATLAB нажмите Export to Workspace.

Экспорт модели на диск

Если выбран пункт Export to Disk то появится окно Export to Disk.



Рисунок 6 Окно сохранения модели на диск

Задайте имя модели и нажмите Save.

Экспорт нескольких моделей

Если модели идут в списке друг за другом, зажмите клавишу Shift и выберите модели курсором мыши.

Если модели не идут подряд в списке, зажмите кнопку Ctrl и выберите модели левой кнопкой мыши.

4 Настройка компенсаторов

SISO Design Tool упрощает процедуру проектирования компенсаторов. В зависимости от того, какие графики открыты – расположения корней, Диаграмма Боде, графики Никольса – существует три способа изменения структуры компенсатора:

  • Интерактивные графики позволяют настраивать коэффициент усиления компенсатора и регулировать динамические характеристики (нули и полюса).

  • Меню правой кнопки мыши позволяет добавлять/удалять нули и полюса и настраивать вид графика (например, добавлять сетку, изменять масштаб, добавлять ограничения или настраивать свойства графика).

  • Окно редактора компенсатора (Edit Compensator) представляет GUI с областями для ввода с клавиатуры коэффициента усиления и расположения нулей/полюсов.

В SISO Design Tool можно использовать любой из этих способов на графике расположения корней, диаграммах Боде разомкнутого контура и предфильтра или графиках Никольса. После добавления нулей и полюсов в компенсатор можно изменять их местоположение, перетягивая их курсором мыши. SISO Design Tool разработан так, что изменения любого из графиков автоматически приводит к изменению остальных. В частности, панель Current Compensator всегда отражает текущую схему компенсатора.

5 Расположение корней

Можно настроить компенсатор, используя метод расположения корней. На рисунке ниже показаны импортированные модели компенсатора и объекта управления; используем меню правой кнопки и свойства интерактивной графики чтобы добавить, изменить и удалить нули и полюса компенсатора.


Используйте меню правой кнопки чтобы добавить нули и полюса в схему компенсатора

Панель статуса показывает советы по использованию SISO Design Tool

Передвиньте любой из красных квадратов чтобы изменить коэффициент усиления компенсатора

Можно изменить положение нулей и полюсов компенсатора (красные 0 и х соответственно) с помощью мыши

Сини х и 0 обозначают полюса и нули объекта управления. Их нельзя передвигать


Рисунок 7 График расположения корней

Самым простым методом настройки является изменение коэффициента усиления компенсатора, который по умолчанию равен 1. Чтобы сделать это просто выделите мышкой на графике красные квадраты и переместите их вдоль кривой.

Чтобы было удобней отслеживать влияние производимых изменений на характеристики системы, одновременно с графиком расположения корней постройте переходную характеристику замкнутого контура. Для этого в меню Analysis выберите пункт Other Loop responses и в появившемся окне нажмите OK.

Однако, можно заметить, что увеличение коэффициенту усиления (КУ) приводит к повышению коллебательности системы. Дальнейшее увеличение КУ приводит к неустойчивому состоянию системы, следовательно достигнуть всех требований только с помощью изменения КУ невозможно. Кроме коэффициента усиления компенсатор характеризуется также нулями и полюсами. Поэтому после настройки КУ можно добавить нули или полюса в компенсатор.

Попробуйте добавить комплексно сопряженную пару полюсов. Для этого в меню правой кнопки выберите пункт Add Pole/Zero>Complex Pole. Постарайтесь расположить полюс левее пары полюсов, расположенных близко к мнимой оси. При этом графики Боде, расположения корней и переходной характеристики изменятся с учетом добавленного полюса. На графике расположения корней новые полюса будут обозначены красными ‘x’.



Рисунок 8 Результат добавления комплексно сопряженной пары полюсов

Добавление нулей в компенсатор осуществляется аналогичным образом. Постарайтесь добавить пару комплексно сопряженных нулей немного левее пары только что добавленных полюсов.

Процесс проектирования компенсатора может включать некоторые ошибки и неточности. Поэтому перемещайте нули и полюса компенсатора или полюса замкнутого контура по графику расположения корней пока не достигните требуемых характеристик.

Чтобы задать точные значения нулей и полюсов, используйте окно Edit Compensator, с помощью которого можно изменить значение КУ и местоположение нулей и полюсов компенсатора.

Окно Edit Compensator можно вызвать тремя способами: Выбрать пункт Edit Compensator меню Edit; выбрать пункт Edit Compensator в меню правой кнопки; дважды щелкнув мышкой по панели Current Compensator.


Переключатель между форматами местоположение Нуля/полюса (Zero/Pole Location) и Затухание/Собственная частота (Damping/Natural Frequency)

Используйте эти области чтобы задать точное местоположение нулей и полюсов.

Используйте область Gain чтобы задать КУ компенсатора


Рисунок 9 Окно Edit Compensator

6 Диаграмма Боде разомкнутого контура

SISO Design Tool поддерживает диаграмму Боде разомкнутого контура системы. Можно использовать меню правой кнопки и характеристики интерактивных графиков, чтобы добавить, изменить и удалить нули и полюса. На следующем рисунке показаны некоторые характеристики диаграммы Боде разомкнутого контура.


Перетащите график величины боде вверх или вниз чтобы отрегулировать коэффициент усиления компенсатора

Можно перемещать полюса и нули компенсатора (красные х и 0 соответственно) с помощью мыши

Синие х и 0 обозначают полюса и нули объекта управления. Их нельзя передвигать.

Панель статуса показывает советы по использованию SISO Design Tool

Можно регулировать параметры режекторного фильтра передвигая их с помощью мыши

Используйте меню правой кнопки чтобы добавить полюса и нули в компенсатор


Рисунок 10 Диаграмма Боде разомкнутого контура

С помощью диаграммы Боде можно задать запасы устойчивости по амплитуде и фазе, время переходного процесса, перерегулирование, настроить полосу пропускания и добавить режекторный фильтр для снижения помех.

Самым простым способом уменьшения времени переходного процесса является увеличение коэффициента усиления компенсатора. Чтобы увеличить коэффициент усиления, необходимо навести курсор мыши на график величины Боде (при этом указатель мыши превратиться в изображение руки), выделить кривую величины Боде и, удерживая левую кнопку мыши, передвинуть ее вверх. Новое значение КУ появится в текстовом окне панели Current Compensator. Кроме того, можно не передвигая график величины Боде просто задать желаемое значение КУ в этом окне.

Чтобы настроить полосу пропускания выделите мышкой график величины Боде и перетаскивайте его до тех пор, пока не увидите, что график пересекает линию 0 дБ в заданном месте (частота среза равна желаемому значению). При этом КУ компенсатора также изменяется.

По умолчанию в нижнем левом углу окна графика Боде показывается запасы устойчивости по амплитуде и фазе, а также информация об устойчивости замкнутого контура системы.

При наличии статической ошибки простейшим способом ее устранения является добавление интегратора. Это можно сделать с помощью меню правой кнопки.

Обратите внимание, что добавление интегратора изменяет частоту среза системы а также запас устойчивости по амплитуде.

После добавления интегратора и настройки КУ компенсатора на графике расположения корней в начале координат появится красный ‘x’.

Однако КУ нельзя увеличивать бесконечно, т.к. это вызывает уменьшение запасов устойчивости и может привести систему к неустойчивому состоянию. Поэтому одним из эффективных способов проектирования компенсатора остается добавление нулей и полюсов.

Например, чтобы снизить время нарастания можно добавить контур предварения. Чтобы сделать это, в меню правой кнопки выберите пункт Add Pole/Zero>Lead. Курсор мыши превратится в ‘x’. Поместите ‘x’ на диаграмме величины Боде немного справа от самого правого полюса и нажмите кнопку мыши. После это отрегулируйте параметры предварения. Чтобы улучшить скорость процесса, поместите ноль контура запаздывания ближе к самому левому полюсу объекта управления (синий ‘x’). Теперь попробуйте передвинуть полюс контура предварения вправо. При этом будет увеличиваться запас устойчивости по фазе. Во время настройки параметров обращайте внимание на переходную характеристику замкнутого контура. На ней отражаются все производимые изменения. Чтобы убедиться, что характеристики переходного процесса соответствуют заданным, щелкните правой кнопкой мыши в поле графика переходного процесса и в появившемся меню в пункте Characteristics выберите интересующие вас характеристики.

7 График Никольса разомкнутого контура

Альтернативным методом проектирования компенсатора является расчет по графику Никольса разомкнутого контура. Можно использовать меню правой кнопки и характеристики интерактивных графиков чтобы добавить, изменить и удалить нули и полюса. На следующем рисунке показаны некоторые характеристики графика Никольса разомкнутого контура.


Коричневые прямые показывают запасы устойчивости по амплитуде и фазе

Синие х и 0 обозначают полюса и нули объекта управления. Их нельзя передвигать.


Используйте меню правой кнопки чтобы добавить полюса и нули в компенсатор

.


Можно перемещать полюса и нули компенсатора (красные х и 0 соответственно) с помощью мыши

Панель статуса показывает советы по использованию SISO Design Tool


Рисунок 11 График Никольса разомкнутого контура

Чтобы настроить КУ компенсатора, можно просто переместить график Никольса вниз или вверх с помощью мыши.

При наличии статической ошибки простейшим способом ее устранения является добавление интегратора. Это можно сделать с помощью меню правой кнопки.

Обратите внимание, что добавление интегратора запас устойчивости по амплитуде. Так как теперь запасы устойчивости по амплитуде и фазе имеют конечные значения, то на графике Никольса появится вертикальная линия, характеризующая запас по амплитуде, и горизонтальная линия, характеризующая запас по фазе.


Коричневые прямые показывают запасы устойчивости по амплитуде и фазе


Рисунок 12 Добавление интегратора

Снижение времени нарастания требует увеличения КУ компенсатора, но увеличение КУ снижает запасы устойчивости по амплитуде и фазе и увеличивает перерегулирование. В этом случае нужно добавить контур предварения, чтобы избирательно увеличить КУ выше частоты среза.

Чтобы добавить контур предварения, в меню правой кнопки выберите пункт Add Pole/Zero>Lead. После этого курсор превратиться в ‘x’. Щелкните левой кнопкой мыши по кривой Никольса чтобы добавить контур. Изменить положение контура можно, перетащив его полюс с помощью мыши. Текущее положение полюса будет отображаться в панели статуса.


Пунктирная линия показывает возможное положение полюса


Рисунок 13 Перемещение полюса контура предварения

8 Диаграмма Боде предфильтра

SISO Design Tool поддерживает диаграмму Боде предфильтра. Можно использовать меню правой кнопки чтобы добавить, изменить и удалить нули и полюса, а также регулировать их, перетаскивая с помощью мыши. На следующем рисунке показаны некоторые характеристики диаграммы Боде предфильтра.


Зеленая кривая – это величина Боде предфильтра. Передвигайте ее вверх или вниз чтобы изменить коэффициент усиления предфильтра

Используйте меню правой кнопки чтобы добавить полюса и нули в компенсатор

.


Панель статуса показывает советы по использованию SISO Design Tool

Красная кривая – это отклик замкнутого контура

Зеленый ‘х’ – полюс предфильтра. Его можно перемещать с помощью мыши


Рисунок 14 Диаграмма Боде предфильтра

9 Использование меню правой кнопки для проектирования

компенсаторов

Самым быстрым способом проектирования компенсаторов является проектирование с помощью меню правой кнопки. SISO Design Tool включает меню правой кнопки для всех доступных в приложении графиков, включая график расположения корней, диаграммы Боде разомкнутого контура, график Никольса и диаграммы Боде предфильтра. Пункты меню для всех этих графиков идентичны, однако, ограничения объекта отличаются в зависимости от графика, в котором вызвано это меню.

Меню правой кнопки можно использовать, чтобы добавить нули, полюса, предварение, запаздывание, и режекторные фильтры.



Рисунок 15 меню правой кнопки

10 Добавление нулей и полюсов к компенсатору

С помощью пункта Add Pole/Zero меню правой кнопки можно добавить к схеме компенсатора действительные и комплексные нули и полюса, контуры предварения и запаздывания, режекторные фильтры.



Рисунок 16 подменю Add Pole/Zero

Доступными являются следующие конфигурации нулей и полюсов:

  • Real Pole (действительный полюс).

  • Complex Pole (комплексный полюс).

  • Integrator.

  • Real Zero (действительный ноль).

  • Complex Zero (комплексный ноль).

  • Lead (предварение).

  • Lag (запаздывание).

  • Notch (режекция).

При выборе любого пункта, кроме integrator и differentiator, курсор мыши превращается в ‘x’. Чтобы добавить выбранный пункт в схему компенсатора, наведите ‘x’ на требуемое место на графике и нажмите левую кнопку мыши. График автоматически измениться.

11 Добавление режекторного фильтра

Если вы знаете, что на систему оказывают действие помехи определенной частоты, то можно использовать режекторный фильтр, чтобы снизить КУ системы при этой частоте. Чтобы добавить режекторный фильтр, выберите в меню правой кнопки пункт Add Notch и расположите фильтр на заданной частоте. Рядом с курсором появится черный ‘x’; разместите его на частоте, которую вы хотите подавить.



Рисунок 17 Вид графиков расположения корней и диаграмма Боде при добавлении режекторного фильтра

Чтобы более подробно рассмотреть параметры фильтра, увеличим область режекторного фильтра на диаграмме Боде. Для этого в меню правой кнопки диаграммы Боде выберем пункт Zoom X-Y выделим область левой кнопкой мыши и отпустим кнопку.


Перемещайте черные ромбы чтобы изменить ширину режекции. Переместите красный  вниз чтобы усилить режекцию.


Рисунок 18 Изменение параметров режекторного фильтра

Чтобы лучше понять как изменение параметров фильтра действует на него рассмотрим передаточную функцию режекторного фильтра.



Настраиваемыми являются три параметра , и . Отношение задает силу режекции, а - собственная частота режекции. Следующий рисунок демонстрирует, как перемещение красного  и черных ромбиков изменяет эти параметры а, следовательно, и передаточную функцию предфильтра.


Изменяет при постоянном значении (т.е. изменяет ширину режекции при сохранении силы режекции постоянной)

Изменяет (силу режекции)

Изменяет


Рисунок 19 Параметры режекторного фильтра

12 Добавление предфильтра

В SISO Design Tool предфильтр обычно выполняет следующие функции:

  • Отслеживание прямого контура для снижения нагрузки контура обратной связи (при низких запасах устойчивости).

  • Фильтрация высокочастотной составляющей в управляющем воздействии для ограничения перерегулирования и избежания возбуждаемого резонансного режима объекта управления.

Обычный предфильтр – это фильтр низкой частоты, снижающий шум во входном сигнале.

В предфильтр можно добавлять нули и полюса, а также настраивать КУ с помощью методов, используемых для настройки компенсатора.

Если предфильтр не был импортирован, то по умолчанию все его параметры равны нулю. Чтобы быстро создать сглаживающий фильтр низкой частоты, можно просто добавить пару комплексно сопряженных полюсов.

13 Просмотр откликов контура и системных данных

SISO Design Tool позволяет просматривать отклики контура вашей системы. Чтобы увидеть доступные отклики в частотной и временной областях, выберите меню Analysis.



Рисунок 20 Меню Analysis

Выберите желаемый отклик. Откроется LTI Viewer с требуемым графиком. Например, если выбран пункт Response to Step Command, то на экран выведется переходная характеристика замкнутого контура.

14 Просмотр особых откликов

Если в меню Analysis выбран пункт Other Loop responses, то появится окно Response Plot Setup.


Диаграмма контура

Графики и их содержимое


Рисунок 21 окно Response Plot Setup

Окно состоит из нескольких разделов:

Loop Diagram (диаграмма контура)

В верхней части окна Response Plot Setup расположена диаграмма контура. Эта блочная диаграмма показывает структуру с обратной связью вашей системы.

Также в этом окне, рядом с диаграммой контура, показаны две передаточные функции:

  • Loop transfer (передаточная функция контура) – определяется как произведение функций компенсатора (C), объекта управления (G) и датчика (Н) (CGH).

  • Sensitivity function (функция чувствительности) – определяется как 1/(1+L), где

L – передаточная функция контура.

Plots (графики)

Можно задать до шести графиков в одном окне LTI Viewer. По умолчанию, в окне Response Plot Setup задан один график переходной характеристики. Чтобы добавить график, выберите строку “2.None” из списка графиков и задайте для него новый тип графика в поле Change to. Можно выбрать любой из доступных в LTI Viewer графиков. Чтобы удалить график выберите “None”.

Contents of Plots (содержимое графиков)

После выбора типа графика можно выбрать несколько передаточных функций замкнутого и разомкнутого контура для вывода на этом графике. Можно получить отклики разомкнутого контура для каждого элемента схемы, включая компенсатора (C), объекта управления (G), предфильтр (F) и датчика (Н). Кроме того, доступны передаточная функция контура и функция чувствительности.

Точки ввода/вывода для построения откликов замкнутого контура показаны на диаграмме контура.

15 Просмотр системных данных

Данные о модели можно просмотреть, выбрав в меню View пункт System Data.



Рисунок 22 Окно System Data

В окне System Data показаны нули и полюса импортированных моделей объекта управления и датчика. Чтобы увидеть соответствующую передаточную функцию нажмите кнопку Show transfer Function.

16 Хранение и извлечение схем

SISO Design Tool поддерживает графический интерфейс пользователя (GUI) для хранения и извлечения схем компенсаторов. Каждая схема состоит из пары (C,F) моделей компенсатора и предфильтра.

Чтобы открыть окно Compensator Design Archive, выберите в меню Compensators пункт Store/Retrieve.



Рисунок 23 Окно Compensator Design Archive

Это окно используется как для хранения, так и для извлечения схем компенсаторов. Чтобы сохранить схему, задайте имя, под которым вы хотите ее сохранить, и нажмите кнопку Store. Чтобы восстановить любую из схем предфильтра и/или компенсатора, созданных в SISO Design Tool, щелкните правой кнопкой мыши по имени схемы, которую вы хотите восстановить и нажмите Retrieve.

17 Создание и редактирование ограничений

При проектировании компенсаторов обычно имеется ряд характеристик схемы, требующих определенного времени установления, коэффициента затухания и других параметров. В SISO Design Tool предусмотрен ряд ограничений, помогающих упростить задачу достижения характеристик схемы. Окно New Constraint, позволяющее создавать ограничения, автоматически изменяет вид, показывая ограничения, доступные для выбранного типа графика. Чтобы открыть окно New Constraint щелкните правой кнопкой мыши в поле графика и в появившемся меню выберите пункт Design Constraints>New.



Рисунок 24 Окно New Constraint

Для каждого графика набор ограничений разный.

18 Создание ограничений для графика расположения корней

Для графика расположения корней доступными являются следующие виды ограничений:

  • Settling Time (время установления сигнала).

  • Percent Overshoot (перерегулирование в %).

  • Damping Ratio (коэффициент затухания).

  • Natural Frequency (собственная частота).

В меню Constraint type выберите тип ограничения. В каждом случае, чтобы задать ограничение, введите значение в поле Constraint parameters. Можно выбрать любое или все ограничения сразу, или более одного ограничения одного и того же типа.

Settling time (время установления сигнала)

Если задано время установления на непрерывном графике расположения корней, то на графике расположения корней появится вертикальная линия в месте расположения полюса, связанного с заданным значением (используется аппроксимация первого порядка). В случае с дискретным временем ограничение имеет вид кривой.

Percent Overshoot (перерегулирование в %)

При заданий перерегулирования в случае непрерывного графика расположения корней на нем появляются два луча, начинающиеся в начале координат. Эти лучи представляют собой расположение полюсов, связанных со значением перерегулирования (используется аппроксимация второго порядка). В случае с дискретным временем ограничения представляют собой две кривых, начинающихся в точке (1,0) и встречающихся на действительной оси в левой полуплоскости.

Ограничения перерегулирования (п.р.) могут также быть заданы через коэффициент затухания с помощью уравнения:



где - коэффициент затухания.

Damping Ratio (коэффициент затухания)

При задании коэффициента затухания в случае с непрерывным временем на графике расположения корней появляются два луча, начинающихся в начале координат. Эти лучи представляют собой местоположение полюсов, связанных с заданным значением коэффициента затухания. В случае с дискретным временем, ограничения появляются на графике в виде кривых, начинающихся в точке (1,0) и встречающихся на действительной оси в левой полуплоскости.

Natural Frequency (собственная частота)

При задании собственной частоты на графике расположения корней появится полукруг с центром в начале координат. Радиус полукруга равен собственной частоте.

19 Задание ограничений для диаграмм Боде разомкнутого контура и предфильтра

Для диаграмм Боде как разомкнутого контура, так и предфильтра доступны следующие ограничения:

  • Upper Gain Limit (верхний придел коэффициента усиления);

  • Lower Gain Limit (нижний придел коэффициента усиления).

При задании любых из вышеперечисленных ограничений на графике величины Боде появятся линии. Чтобы задать верхний или нижний приделы коэффициента усиления, необходимо ввести диапазон частот, придельное значение и/или наклон в децибелах на декаду в соответствующих окнах панели Constraint Parameters (параметры ограничений).

Upper Gain Limit (верхний придел коэффициента усиления)

Можно задать верхний придел коэффициента усиления, который появится на графике величины Боде в виде прямой. Для задания ограничения необходимо ввести приделы частот, верхний придел коэффициента усиления в децибелах и наклон в Дб/декада.

Нижний придел коэффициента усиления задается аналогичным образом.

20 Задание ограничений для графика Никольса разомкнутого

контура

Для графика Никольса разомкнутого контура можно задать следующие виды ограничений:

  • Phase Margin (запас устойчивости по фазе);

  • Gain Margin (запас устойчивости по амплитуде);

  • Closed-Loop Peak Gain (максимальный коэффициент усиления замкнутого контура).

При заданий любых из вышеперечисленных ограничений на графике Никольса появляются линии или кривые. Чтобы задать ограничения, необходимо ввести их значение в панели Constraint Parameters. Можно задать любое ограничение ил несколько ограничений одного типа.

Phase Margin (запас устойчивости по фазе)

Чтобы задать запас устойчивости по фазе, необходимо ввести минимальное значение фазы в заданном месте. Например, можно задать минимальное значение 300 при пересечении -1800. Задаваемый запас устойчивости по фазе должен быть положительным числом. Местоположение должно быть -1800 плюс кратное 360 число. Если точка была задана неверно, то будет выбрано ближайшее возможное значение.

Gain Margin (запас устойчивости по амплитуде)

Задайте запас устойчивости по амплитуде в заданном месте. Например, можно задать минимальное значение 20 дБ. при пересечении -1800. Местоположение должно быть -1800 плюс кратное 360 число. Если точка была задана неверно, то будет выбрано ближайшее возможное значение.

Closed-Loop Peak Gain (максимальный коэффициент усиления замкнутого контура)

Задайте максимальный коэффициент усиления замкнутого контура в определенном месте. Задаваемое ограничение может быть как положительным так и отрицательным в дБ. Ограничение повторяет очертания сетки графика Никольса, поэтому сетку рекомендуется включать при использовании этих ограничений.

21 Редактирование ограничений

Чтобы изменить существующие ограничения, щелкните по линии ограничения левой кнопкой мыши. На линии ограничений появятся два черных квадрата, а курсор мыши превратится в большой черный крест. Существует два способа редактирования ограничений:

  • Щелкнуть по линии ограничений кнопкой мыши и перетащить ее. В этом случае форма линии не меняется, меняется лишь местоположение ограничений.

  • Щелкнуть по черному квадрату на линии ограничений и перетащить его. В этом случае можно вращать, растягивать и/или сжимать линию ограничений.

Например, на диаграмме боде можно передвинуть линию ограничения верхнего значения коэффициента усиления, щелкнув по ней кнопкой мыши и просто перетащив в любое место графика. Если не трогать черный квадрат, то длинна и наклон линии при этом не изменятся. С другой стороны, можно изменить наклон линии ограничения верхнего значения коэффициента усиления, выделив мышкой один из черных квадратов и повернув линию. В любом случае, все изменения ограничений отображаются в панели статуса внизу окна SISO Design Tool.


Вращайте четный квадрат чтобы изменить наклон линии ограничений. Можно также сжать или растянуть линию ограничений перетаскивая черный квадрат.

Щелкните по серой линии копкой мыши и удерживайте ее. Теперь линию можно перемещать вверх/вниз или влево/вправо

Панель статуса показывает обновленные значения ограничений


Рисунок 25 Пример изменения ограничений

Также для редактирования ограничений можно выбрать в меню правой кнопки пункт Design Constraints>Edit. Появится окно редактора ограничений Edit Constraints.



Рисунок 26 Окно Edit Constraints

Чтобы изменить ограничения, выберите тип ограничения в поле Constraint или щелкните мышкой по лини ограничения в поле графика и измените значения в поле Constraints parameters. Если у вас есть ограничения на других графиках, то их можно отредактировать непосредственно из этого же окна, выбрав в окне Editor соответствующий график.

22 Удаление ограничений

Чтобы удалить ограничение наведите курсор мыши на линию ограничения на графике. Курсор превратиться в большой крест. Нажмите правую кнопку мыши. В появившемся меню выберите Delete. Также ограничение можно удалить, выделив его левой кнопкой мыши и нажав затем клавишу Backspace или Delete клавиатуры.

Кроме того, если добавление ограничения было последним выполненным действием, то его можно удалить, выбрав в меню Edit пункт Undo Add Constraint или нажав Ctrl+Z.

23 Текущий компенсатор

Панель Current Compensator (текущий компенсатор) показывает структуру проектируемого компенсатора. По умолчанию компенсатор задан с единичным коэффициентом усиления без нулей и полюсов. После добавления полюсов и/или нулей панель Current Compensator отображает структуру компенсатора в формате нули/полюса/коэффициент усиления.



Рисунок 27 Панель текущего компенсатора

Коэффициент усиления компенсатора можно изменить в текстовом окне. Чтобы изменить нули и полюса, щелкните по окну мышкой. Откроется окно Edit Compensator.

При вводе систем с дискретным временем вид панели Current Compensator меняется.



Рисунок 28 Панель текущего компенсатора при работе с дискретным временем (период дискретизации 0.001 с.)

Здесь w = (z-1)/Ts. Это сделано для упрощения представления. Обратите внимание, что коэффициенты почти совпадают с коэффициентами при непрерывном времени.

Если на месте полинома в окне компенсатора появятся обозначения NunC и DenC, это значит, что числитель и знаменатель передаточной функции слишком большие для отображения.

24 Переход от непрерывного времени к дискретному и обратно

Чтобы преобразовать систему из непрерывной в дискретную, выберите в меню Tools пункт Continuous/Discrete Conversions. Откроется окно Continuous/Discrete Conversions.



Рисунок 29 Окно Continuous/Discrete Conversions

Выберите период квантования в поле Sample time и метод восстановления для объекта управления (G), компенсатора (С), предфильтра (F) и датчика (Н). Доступными являются следующие алгоритмы восстановления:

  • Zero-Order Hold (приближение нулевого порядка).

  • First-Order Hold (приближение первого порядка).

  • Tustin (аппроксимация тастина).

  • Tustin w/Prewarping (аппроксимация тастина с предварительным квантование).

  • Match Zero/Pole (сопоставление нулей/полюсов).

Если в качестве метода восстановления выбран аппроксимация тастина с предварительным квантование, то появляется дополнительное окно, в котором необходимо задать частоту предварительного квантования.

Чтобы преобразовать систему обратно в непрерывную, выберите в меню Tools пункт Continuous/Discrete Conversions. Откроется окно Continuous/Discrete Conversions, в котором надо поставить галочку в строке Continues time.
  1   2

Похожие:

Лабораторная работа №7 iconЛабораторная работа №1
Лабораторная работа Выполнение расчетов с использованием программирования в среде Visual Basic for Applications (vba). 8
Лабораторная работа №7 iconЛабораторная работа №1 Работа с массивами и матрицами
Цель работы: закрепить знания по табличным формулам, приобрести навыки решения задач на использование формул и функций массивов в...
Лабораторная работа №7 iconЛабораторные работы.  Лабораторная работа №1. 

Лабораторная работа №7 iconЛабораторная работа «Анимация в Photoshop» Работа №1
...
Лабораторная работа №7 iconФедеральное агентство по образованию 
Лабораторная работа №1 Основы работы в Excel   4 
Лабораторная работа №7 iconЛабораторная работа №1
«Геоинформационные технологии сбора и обработки информации» в среде MapInfo Professional
Лабораторная работа №7 icon      ofs201ill  Лабораторная работа  SharePoint Server 2010:  взгляд администратора   
Прежде, чем начать   4 
Лабораторная работа №7 iconЛабораторная работа №1 Задание для работы
Абзацный отступ устанавливается «движком» на координатной линейке на 1,25-1,5 см
Лабораторная работа №7 iconЛабораторная работа  №1
Курс «Инструментальные средства анализа экономических данных, эф спбГУ, каф. Исэ»
Лабораторная работа №7 iconЛабораторная работа №2
Для загрузки Windows xp необходим следующий минимальный набор файлов, расположенных
Разместите кнопку на своём сайте:
kak.znate.ru


База данных защищена авторским правом ©kak.znate.ru 2012
обратиться к администрации
KakZnate
Главная страница