Описание программы Гелиос 




Скачать 77.65 Kb.
PDF просмотр
НазваниеОписание программы Гелиос 
Дата конвертации02.01.2014
Размер77.65 Kb.
ТипДокументы
Описание программы Гелиос 
 
Назначение программы.................................................................................................................2 
Требования к оборудованию ........................................................................................................3 
Схема соединительно кабеля........................................................................................................4 
Установка программы...................................................................................................................5 
Интерфейс пользователя...............................................................................................................6 
База узлов учета.............................................................................................................................7 
Настройка канала связи ................................................................................................................9 
Параметры ....................................................................................................................................12 
Окно "Монитор обменов" ...........................................................................................................13 
Организация модемной связи.....................................................................................................14 
Настройка удаленного модема ...................................................................................................15 
Настройка местного модема.......................................................................................................17 
Работа с GSM-модемом ..............................................................................................................19 
Установка связи с корректором .................................................................................................21 
Настройки прибора......................................................................................................................22 
Чтение текущих показаний.........................................................................................................24 
Запись текущих показаний .........................................................................................................25 
Чтение архивов газового корректора Гелиос............................................................................26 
Формирование отчета..................................................................................................................27 
Предварительный просмотр и печать отчета............................................................................28 
Сохранение данных на жесткий диск........................................................................................29 
Чтение данных с жесткого диска ...............................................................................................30 

Назначение программы 
Программа  Гелиос  (в  дальнейшем  программа)  предназначена  для  чтения  данных  из 
газового корректора Гелиос, и подготовки отчетных ведомостей о потреблении газа. 
Программа обеспечивает: 
•  считывание  данных  о  параметрах  настройки  газового  корректора,  их 
изменение в соответствии с параметрами объекта и запись обратно в корректор 
•  считывание  архивных  данных  (суточных,  месячных  и  архива  событий)  о 
параметрах газопотребления из газового корректора Гелиос при непосредственном 
подключении к компьютеру по интерфейсу RS232 по запросу оператора; 
•  считывание текущих показаний корректора; 
•  подготовку  отчетных  ведомостей  о  газопотреблении  и  сохранение  их  в 
формате MS Excel или двоичном; 
•  вывод отчетных ведомостей на печать. 

Требования к оборудованию 
Персональный компьютер, должен удовлетворять требованиям: 
•  объем оперативной памяти не менее 32 Мбайт; 
•  наличие свободного СОМ-порта; 
•  операционная  система Windows 98, Windows ME, Windows 2000, Windows 
XP; 
•  Internet Explorer с версией не менее 5.0. 


Схема соединительно кабеля 
На  рисунке  приведена  схема  соединительно  кабеля  для  работы  по  интерфейсу RS-232 
(прямое соединение с прибором): 
  
 
 Для  работы  с  модемом  следует  использовать  стандартные  полные  модемные  кабели, 
продающиеся в комплекте с модемом или кабели, спаянные по схеме "один в один". 
 
  

Установка программы 
Для установки программы необходимо: 
•  закрыть все работающие приложения; 
•  запустить на исполнение дистрибутив программы Gelios.ехе; 
•  следовать инструкциям программы установки. 
ВНИМАНИЕ!  Если  программа  уже  была  установлена  на  компьютер  необходимо  ее 
деинсталлировать. (Пуск-Настройка-Панель  управления-Установка  и 
удаление программ-Гелиос-Удалить

 Программа 
после 
установки 
находится 
на 
жестком 
диске 
в 
каталоге 
$WIN_DRIVE$\Program Files\Гелиос.  Там  же  находится  утилита  для  деинсталляции 
программы. 
 
 
 


Интерфейс пользователя 
При запуске программы на экран выводится главное окно программы 
Программа  имеет  стандартный  интерфейс,  включающий  панель  меню  и  панель 
управления. Команды на панели управления дублируют команды меню. 
Панель управления и строка состояния могут быть отключены во вкладке Вид на панели 
меню. 



База узлов учета 
Окно базы узлов учета отображает структуру зарегистрированных узлов учета и приборов 
внутри  узлов  учета.  Узлы  учета  (и  параметры  приборов)  можно  добавлять,  удалять, 
редактировать.  
 
Для  выполнения  операции  добавления,  редактирования  или  удаления  элемента  следует 
выделить  соответствующий  элемент  и  нажать  соответствующую  кнопку.  Так  для 
добавления  нового  узла  учета  следует  выделить  элемент  "Все  узлы"  и  нажать  кнопку 
"Добавить".  Для  добавления  прибора  в  узел  учета  необходимо  выделить  узел  учета  и 
нажать "Добавить". И т.д. 
При  добавлении  узла  учета  обязательно  необходимо  выбрать  тип  соединения  и  при 
необходимости ввести номер телефона. Если требуется выход на городскую линию, то для 
ожидания гудка после набора префикса АТС надо ввести символ "," или "W". Например 
для  звонка на  городской  номер 1234567 через  местную  АТС  с  префиксом 9 надо  ввести 
такой номер телефона: 9,1234567. 
 


При  добавлении  прибора  внутрь  узла  учета  обязательно  необходимо  ввести  название 
прибора  для  идентификации  и  сетевой  адрес.  Сетевой  адрес  служит  для  адресации 
запросов  внутри  сети  приборов.  Обращение  к  газовому  корректору  происходит  по 
определенному  сетевому  адресу.  Если  несколько  приборов  объединены  в  сеть,  то 
обращение к каждому из них должно быть адресным. Т.е. задаваемый в этом поле адрес 
должен  быть  равен  соответствующему  полю  в  настройках  прибора.  Введенный  сетевой 
адрес  должен  соответствовать  сетевому  адресу  внутри  прибора  (меню  Настройки 
прибора->Сетевой адрес
). Возможен ввод сетового адреса 0 в базе узлов учета. Это так 
называемый широковещательный режим, при котором любой прибор, получивший запрос 
с адресом 0, независимо от собственного сетевого адреса, будет отвечать на запрос. Этот 
режим допускается только при соединении типа точка-точка, т.е. когда отсутствует сеть 
приборов.  
 
ВНИМАНИЕ!  Изменение  сетевого  адреса  программой  должно  производиться  только 
при 
прямом 
соединении 
типа 
точка-точка 
в 
режиме 
широковещательного запроса (сетевой адрес 0). 
  


Настройка канала связи 
Окно настройки канала связи имеет следующий вид: 
 
Для настройки канала связи необходимо установить: 
•  номер Сom-порта; 
•  скорость передачи данных; 
•  количество  попыток  запросов  и  интервал  между  ними.  Используется  при 
плохом качестве канала связи или когда прибор не отвечает; 
•  аппаратный  тайм-аут  чтения.  Флажок  "Использовать  расчетный..."  должен 
быть установлен; 
  
Примечание  Скорости  передачи  данных  в  приборе  и  компьютере  должны  быть 
одинаковы 
  
Примечание 
•  Флажок  "Использовать  расчетный  тайм-аут  чтения" 
необходимо  снять  при  неустойчивой  связи  и  вводить  значения, 
определяемые  экспериментальным  путем.  Расчетное  значение 
этой  величины  для  скорости 9600 бит/с  составляет 125 мс. 
Рекомендуемый  диапазон  изменения  от 150 до 500 мс.  При 
увеличении  значения  устойчивость  связи  возрастает.  При 
увеличении  значения  суммарное  время  считывания  данных 
возрастает. 

 Состав команд меню 
Файл: 
•  Открыть (Ctrl+O) - чтение данных с диска; 
•  Сохранить (Ctrl+S) - сохранение файла; 
•  Печать (Ctrl+P) - вывод отчета на принтер; 
•  Настройки  страницы - позволяют  настроить  параметры  печатаемой 
страницы (размер, ориентация и т.д.); 
•  Предварительный просмотр; 
•  Выход - выход из программы. 
Вид: 
•  Панель управления - скрывает и показывает панель управления; 
•  Строка состояния - скрывает и показывает строку состояния; 
•  Монитор - скрывает и показывает окно "Монитор обменов". 
Соединение: 
•  Установить связь - инициирует процесс установки связи с прибором; 
•  Разорвать связь - позволяет разорвать связь с прибором; 
•  Остановить процесс - прекращает выполнение запросов к прибору. 
Отчеты и действия: 
•  Архивный отчет - позволяет задать параметры выводимого отчета; 
•  Настройки  прибора - отображает  настройки  газового  корректора, 
позволяет их записать в прибор; 
•  Чтение  текущих  показаний - позволяет  прочитать  текущие  показания 
газового корректора; 
•  Запись  текущих  показаний - позволяет  записать  в  корректор  значения 
параметров V и Vc, сбросить текущие и накопленные нештатные ситуации. 
Пункт доступен только при нажатой кнопке Доступ в приборе; 
•  Обновить состояние прибора - позволяет перечитать статус прибора. Это 
необходимо  для  контроля  за  состоянием  корректора  (открыт  ли  доступ  к 
изменению  параметров).  Операция  обновление  может  быть  выполнена 
автоматически (см. Параметры); 
•  Установка  даты/времени - позволяет  задать  дату/время  в  корректоре. 
Пункт  доступен  только  при  нажатой  кнопке  Доступ  в  приборе.  Установка 
даты/времени  возможна  только  после  выполнения  операции  Сброс  и  до 
наступления новых суток в приборе; 
•  Выполнить  сброс - позволяет  выполнить  сброс  архивов  в  приборе.  Пункт 
доступен только при нажатой кнопке Доступ в приборе; 
•  Прочитать  весь  архив - позволяет  прочитать  все  имеющиеся  архивные 
записи  из  архивов  всех  типов.  Операция  может  быть  выполнена 
автоматически при установлении связи с прибором (см. Параметры). 
Настройки программы: 
•  Канал связи - позволяет настроить параметры канала связи; 

•  Размер  шрифта - позволяет  изменить  размер  выводимого  на  экран  отчета 
шрифта; 
•  Параметры - позволяет задать настройки программы; 
Help: 
•  Help - вызов встроенной справки программы; 
•  О программе - информация о программе. 


Параметры 
Окно ввода параметров имеет следующий вид: 
 
Позволяет задать следующие настройки программы: 
•  Считывать весь архив при установке связи с прибором. При установленном 
флажке  программа  считывает  все  имеющиеся  в  корректоре  архивные  записи  из 
архивов всех типов. 
•  Печатать  служебные  НС  в  архивных  отчетах.  При  установленном  флажке 
архивные  отчеты  дополняются  столбцами  наличия  нештатных  ситуаций,  не 
имеющих прямого отношения к коммерческому учету; 
•  Проверять статус прибора при открытии меню. При установленном флажке 
программа  автоматически  перечитывает  состояние  прибора.  При  этом,  если  в 
приборе  была  нажата  кнопка  Доступа,  то  после  обновления  статуса  станут 
доступными некоторые дополнительные пункты меню. 
•  Сетевой  адрес.  Обращение  к  газовому  корректору  происходит  по 
определенному  сетевому  адресу.  Если  несколько  приборов  объединены  в  сеть,  то 
обращение к каждому из них должно быть адресным. Т.е. задаваемый в этом поле 
адрес  должен  быть  равен  соответствующему  полю  в  настройках  прибора. 
Допускается ввод значения 0. Это так называемый широковещательный режим, при 
котором  отвечает  любой  прибор,  получивший  запрос  с  адресом 0. 
Широковещательный  режим  допускается  только  при  подключении  типа  точка-
точка (компьютер подключен к единственному прибору). 


Окно "Монитор обменов" 
Окно  "Монитор  обменов"  необходимо  для  отладочных  целей  и  выявления  разного  рода 
неполадок в работе системы Прибор-Программа.  
 
Окно  отображает  наименование  выполняемой  операции,  тип  выполняемого  запроса  и  в 
шестнадцатеричной форме все запросы и ответы прибора, "проходящие" по каналу связи. 
При  помощи  меню  Операции  содержимое  окна  можно  очистить  или  сохранить  как 
текстовый файл. 

Организация модемной связи 
При  подключении  газового  корректора  к  компьютеру  через  модем  применяется  два 
модема: 
•  местный, подключаемый к компьютеру на диспетчерском пункте; 
•  удаленный, устанавливаемый на узле учета. 
Для 
правильной 
работы 
модемы 
должны 
быть 
правильно 
настроены 
(запрограммированы). 
Удаленный  модем  программируется  (Настройка  удаленного  модема)  один  раз  перед 
установкой на узле учета компьютером с помощью программы Гелиос. Настройки (строка 
инициализации) записываются в энергонезависимую память модема. 
Местный модем программируется непосредственно при каждом сеансе связи, поэтому нет 
необходимости  сохранять  настройки.  Строка  инициализации  местного  модема  задается 
при настройке параметров связи. 


Настройка удаленного модема 
1.  Установить  параметры  канала  связи  (номер Com-порта  и  скорость  передачи 
данных) командой Настройки*Канал связи или функциональной клавишей F5. 
Примечание  Скорости  передачи  данных  в  приборе  и  компьютере  должны  быть 
одинаковы. 
2.  Подключить модем к Com-порту и включить питание. 
3.  Выбрать  команду  Сервис*Настройка  удаленного  модема...  на  панели  меню.  В 
раскрывшемся  окне  установить  необходимые  параметры  строки  инициализации 
модема.  
 
Примечание  При выходе из программы измененные параметры настройки сохраняются 
на  жестком  диске.  В  случае  необходимости,  можно  вернуться  к 
первоначальным  настройкам,  нажав  кнопку  "Восстановить  строку  по 
умолчанию" 
4.  Нажать  кнопку  ОК.  В  случае  нормальной  инициализации  модема  в  строке 
состояния  появится  надпись  об  успешном  завершении  операции.  В  противном 
случае на экран будет выведено сообщение об ошибке. 
5.  Отключить модем от компьютера и установить его на узле учета. 
  
Строка инициализации удаленного модема 
При  программировании  удаленного  модема  в  окне  настройки  необходимо  установить 
параметры строки инициализации. По умолчанию строка инициализации имеет вид: 
AT&F&R1E0V0&D0X0S0=2S7=120&W, 
где: 
AT - Внимание! Далее следует команда. 
&F - Загрузка в оперативную память заводского шаблона установок F0; 
&R1 - Модем игнорирует RTS; 
E0 - Выключение эха; 
V0 - Результирующий код отображается в виде цифр; 

&D0 - Подавление DTR. Модем  работает  так,  как  если  бы  сигнал  цепи DTR всегда 
находился в активном состоянии (ON); 
X0 - Установка  содержания  и  вида  результирующих  кодов (OK, CONNECT, RING, NO 
CARRIER, ERROR); 
S0=2 - Количество звонков до ответа в режиме автоответа; 
S7=120 - Количество секунд, которое модем ждет несущую (время ожидания связи). Если 
в  течение  этого  времени  не  будет  установлена  связь,  то  модем  выдаст  компьютеру 
сообщение NO CARRIER; 
&W - Запись текущих установок в энергонезависимую память модема. 
Команды,  входящие  в  состав  строки  инициализации  можно  изменять  в  соответствии  с 
документацией на конкретный тип модема. 
Команды, выделенные жирным шрифтом, являются обязательными. 
  
  
Примечание  У  разных  типов  модемов  одноименные  команды  могут  иметь  разное 
символьное обозначение. Поэтому при программировании модема следует 
пользоваться документацией на конкретный тип модема. 
  

Настройка местного модема 
Параметры  настройки  местного  модема  задаются  в  окне  настройки  параметров  канала 
связи. 
Для настройки необходимо задать: 
•  строку инициализации модема; 
•  режим набора номера, заданный на АТС; 
•  время ожидания соединения (Тайм-аут на модемное соединение). 
•  аппаратный тайм-аут на чтение 
Строка инициализации выдается на модем при каждом вхождении в связь. 
Тайм-аут на модемное соединение определяется количеством звонков до ответа (параметр 
S0),  заданных  на  удаленном  модеме  и  качеством  линии  связи.  Устанавливается 
экспериментально. 
Строка инициализации местного модема 
По умолчанию строка инициализации имеет вид: 
AT&FL1E0V1&D2X4S7=120S10=90 
где: 
AT – Внимание! Далее следует команда. 
&F – Загрузка в оперативную память заводского шаблона установок F0; 
L1 – низкий уровень громкости громкоговорителя; 
E0 – Выключение эха; 
V1 – Результирующий код отображается в виде слов; 
&D2 – нормальная работа DTR. Компьютер должен установить сигнал DTR в ON, иначе 
модем не будет принимать команды; 
X4 – Установка содержания и вида результирующих кодов; 
S7=120 – Количество секунд, которое модем ждет несущую (время ожидания связи). Если 
в  течение  этого  времени  не  будет  установлена  связь,  то  модем  выдаст  компьютеру 
сообщение NO CARRIER
S10=90 – Интервал  времени  исчезновения  несущей,  после  которого  фиксируется  ее 
потеря, в 1/10 с. 
Команды,  входящие  в  состав  строки  инициализации  можно  изменять  в  соответствии  с 
документацией на конкретный тип модема. 

Примечание  Команды, выделенные жирным шрифтом, являются обязательными и их 
нельзя менять! 
  
Примечание  У  разных  типов  модемов  одноименные  команды  могут  иметь  разное 
символьное обозначение. Поэтому при программировании модема следует 
пользоваться документацией на конкретный тип модема 

  
Примечание  Для местных модемов US Robotics строка инициализации должна иметь 
вид: 
AT&F0&B1&M0L1E0V1&D2X4S7=120S10=90 
  
Примечание  Флажок "Использовать расчетный тайм-аут чтения" необходимо снять 
при  неустойчивой  модемной  связи.  Расчетное  значение  этой  величины 
для скорости 9600 бит/с составляет 125 мс. 

Рекомендуемый диапазон изменения от 150 до 500 мс. 
При  увеличении  значения  суммарное  время  считывания  данных 
увеличивается 

  

Работа с GSM-модемом 
Работа  программы  при  организации  связи  с  газовым  корректором  Гелиос  с 
использованием GSM-модемов была протестирована с модемами Simens TC35i
Настройка удаленного модема: 
Было  обнаружено,  что  при  обработке AT команд  модем  ведет  себя  нестандартным 
образом. В частности, если ввести в блоке несколько команд подряд, одна из которых не 
поддерживается  модемом  (например, AT&F&R1E0V0&D0X0), то  модем  вернет 
код OK, несмотря  на  то,  что  одна  или  несколько  команд  не  будут  выполнены  успешно. 
Кроме  того,  при  выполнении  множественных  команд  в  одном  блоке  запись  в 
энергонезависимую память модема происходила не для всех команд блока. 
Поэтому настройку удаленного модема следует проводить поэтапно, записывая одну-две 
команды в блоке. 
Настройку  модема  можно  проводить,  используя  стандартную  утилиту Windows 
HyperTerminal” Для начала работы с HyperTerminal следует: 
1.  Подключить  модем  к  свободному  СОМ–порту  компьютера  стандартным 
модемным кабелем; 
2.  Запустить программу HyperTerminal (Пуск-Программы->Стандартные->Связь-
>HyperTerminal); 
3.  Открыть->Файл –создать Новое подключение; 
4.  Ввести любое имя подключения и нажать ОК
5.  Выбрать СОМ–порт, к которому подсоединен модем; 
6.  Выбрать параметры связи: 
•  скорость обмена 9600 бит/с; 
•  число битов – 8; 
•  четность – нет; 
•  число стоповых битов – 2; 
•  управление потоком - нет; 
•  Набрать AT&V
Если  на  экране  появился  список  настроек  модема,  значит,  все  в  порядке  и  можно 
приступать к настройке. В противном случае, следует выяснить причину, по которой нет 
связи с модемом. 
Строка инициализации удаленного модема: 
AT&FE0V0&D0X0S0=2S7=60+IPR=9600\Q3&W 
Далее  приводится  процедура  настройки  удаленного  модема,  после  которой  было 
установлено устойчивое соединение с прибором: 
•  AT&F
•  ATE0V0
•  AT&D0X0
•  ATS0=2S7=60
•  AT+IPR=9600

•  AT\Q3
•  AT&W
После этого следует кратковременно обесточить модем и набрав AT&V, убедиться 
в  том,  что  все  введенные  настройки  сохранились  в  энергонезависимой  памяти  модема. 
Если  одна  или  несколько  настроек  не  сохранились,  их  следует  ввести  повторно  и 
сохранить в память командой AT&W
После успешной настройки модема, его можно отключить от компьютера и подключить к 
прибору. 
Настройка местного модема: 
Для настройки местного модема можно использовать как программу HyperTerminal, так 
и программу Гелиос
Программа Гелиос производит инициализацию модема при выполнении каждой попытки 
соединения. 
Если  модем  был  предварительно  настроен  программой  HyperTerminal,  то  в  настройках 
программы Гелиос в качестве строки инициализации местного модема следует указать 
ATZ0 
 для загрузки настроек из первого профиля энергонезависимой памяти модема. 
Если для настройки используется Гелиос, то в качестве строки инициализации местного 
модема надо указать 
AT&FL1E0V1&D2X4S7=60S10=90+IPR=9600\Q3
Далее можно установить связь с корректором.  




Установка связи с корректором 
Для установления связи с корректором необходимо: 
•  Подключить корректор к компьютеру с помощью кабеля по интерфейсу RS-
232; 
•  Нажать кнопку  
или выполнить команду Соединение->Установить 
связь
Программа установит связь с корректором и считает его настройки. Процесс вхождения в 
связь  отображается  в  строке  состояния  в  нижней  части  главного  окна  программы.Далее 
можно переходить к чтению отчетов. 
Примечание  Для прекращения связи с корректором выполнить команду Соединение-
>Разорвать связь или нажать кнопку 
 
  
Примечание  Если необходимо прервать процесс чтения данных с прибора без разрыва 
связи,  то  следует  выполнить  команду  Соединение->Остановить 
процесс или нажать кнопку 
 


Настройки прибора 
Для чтения настроек газового корректора Гелиос необходимо: 
Установить связь с корректором (см. Установка связи с корректором); 
В меню Отчет и действия выбрать Настройки прибора...
На экран выводится окно настроек прибора. 
 
Могут быть заданы значения следующих параметров: 
•  P - избыточное давление газа (от 0 до 3,0 бар); 
•  Pб - барометрическое давление (от 0,5 до 1,1 бар); 
•  K - коэффициент сжимаемости газа (от 0,7 до 1,3); 
•  В - вес импульса счетчика объема газа (одно значение из ряда 0,01; 0,1; 1; 10; 100 
м3); 
•  Вт - вес  импульса  телеметрического  выхода  (одно  значение  из  ряда 0; 0,1; 1; 10; 
100 м3; при Вт=0 телеметрический выход отключен); 
•  Тmin - минимальное значение температуры газа (от -31 до 61°С); 
•  Тmax - максимальное значение температуры газа (от -31 до 61°С); 
•  наличие  или  отсутствие  функции  контроля  внешних  воздействий:  короткого 
замыкания  выходного  элемента  счетчика  и/или  обрыва  линии  связи  с  прибором 
(одно из условий: «нет»; «КЗ»; «Обрыв»; «КЗ+Обрыв»); 
•  номер счетчика (расходомера) газа от 00000000 до 99999999; 
•  час отчета (от 0 до 23, 23 – последний час суток); 
•  сетевой адрес корректора (от 1 до 239); 
•  число индицируемых параметров (от 1 до 8). 

Если  на  корректоре  кнопка  Доступ  нажата  не  была,  то  можно  изменить  только  число 
индицируемых  параметров.  При  этом  внизу  окна  расположена  кнопка  “Записать  число 
индиц.параметров
” – ее нужно нажать для записи введенного значения в корректор . 
Для  изменения  значений  других  параметров  необходимо  нажать  на  корректоре  кнопку 
Доступ, после этого внизу окна будет кнопка “Записать все настройки”. По завершении 
редактирования  параметров  необходимо  нажать  эту  кнопку  для  записи  введенных 
изменений в корректор. 


Чтение текущих показаний 
Для чтения текущих показаний газового корректора Гелиос необходимо: 
•  Установить связь с корректором (см. Установка связи с корректором); 
•  В меню Отчет и действия выбрать Чтение текущих показаний...
•  На экран выводится окно Текущие показания
 
Если  необходимо  однократное  чтение,  то  нужно  нажать  ОК,  после  этого  текущие 
показания будут считаны и представлены на экране в виде соответствующей таблицы. 
Для  периодического  считывания  и  отображения  текущих  показаний  необходимо 
установить флажок Циклический опрос… и задать значение периода в секундах. 
Примечание  Если необходимо прервать процесс чтения данных с прибора без разрыва 
связи, то следует выполнить команду Соединение->Остановить процесс 
или нажать кнопку 
 


Запись текущих показаний 
Пункт доступен только после нажатия кнопки Доступ на корректоре. 
  
Обычно  необходимость  выполнения  данной операции  возникает  при  вводе  корректора  в 
эксплуатацию,  при  этом  его  показания  приводятся  в  соответствие  с  показаниями 
расходомера. 
  
Для записи текущих показаний газового корректора Гелиос необходимо: 
•  Установить связь с корректором (см. Установка связи с корректором); 
•  В меню Отчет и действия выбрать Запись текущих показаний...
•  На экран выводится окно Запись текущих показаний
 
После  этого  надо  ввести  требуемые  значения V и Vc, а  также  в  случае  необходимости 
установить  флажки  Сбросить  накопленные  НС  и/или  Сбросить  текущие  НС.  Для 
записи в корректор надо нажать ОК
  
 
  
  
 


Чтение архивов газового корректора Гелиос 
Для чтения архивов газового корректора Гелиос необходимо: 
•  Установить связь с корректором (см. Установка связи с корректором); 
•  Если  флажок  Считывать  весь  архив  при  установке  связи  с  прибором  в 
меню  Параметры  не  установлен,  то  выбрать  пункт  меню  Отчеты  и  действия - 
Прочитать весь архив
 (см. Состав команд меню); 
•  В меню Отчет и действия выбрать Архивный отчет...
•  На экран выводится окно установки параметров чтения архива. 
 
Необходимо выбрать следующие параметры: 
1.  Тип отчета (Суточный, Месячный, Архив событий...); 
2.  Интервал  дат  (только  для  суточного  и  месячного  архивов),  за 
который необходимо вывести архив. 
3.  Нажать ОК. 
Программа выведет на экран отчет о параметрах газопотребления. 
Затем  можно  сохранить  сформированный  отчет  в  файл  (см.  Сохранение  данных  на 
жесткий диск
) и(или) перейти к печати отчета (см. Печать отчета). 

Формирование отчета 
Отчет о параметрах газопотребления можно получить двумя способами: 
•  при непосредственном подключении корректора к компьютеру; 
•  при чтении двоичного файла (с расширением *.gbf) с жесткого диска; 
  
Формирование отчета при непосредственном подключении: 
•  Установить связь с корректорм (см. Установка связи с корректором); 
•  В меню Отчет и действия выбрать Архивный отчет
•  В  раскрывшемся  окне  чтения  архивов  (см.  Чтение  архивов)  установить 
необходимые параметры и нажать ОК; 
•  Сохранить сформированный отчет в файл . При сохранении файла в формате 
xls сохраняется сформированный отчет. При сохранении данных в виде gbf файла 
сохраняются  данные,  на  основе  которых  можно  сформировать  отчеты  по  всем 
архивам и отобразить настройки газового корректора.  (см. Сохранение данных на 
жесткий диск
) и(или) перейти к печати отчета (см. Печать отчета). 
  
Формирование отчета при чтении двоичного файла с жесткого диска: 
•  Выбрать команду Файл->Открыть на панели меню или нажать кнопку  на 
панели управления или нажать комбинацию клавиш Ctrl+O
•  В  раскрывшемся  окне  выбрать  требуемый  файл  с  расширением *.gbf и 
нажать кнопку Открыть
•  В  раскрывшемся  окне  чтения  архивов  (см.  Чтение  архивов)  установить 
необходимые параметры и нажать ОК
•  Сохранить  сформированный  отчет  в  файл  (см.  Сохранение  данных  на 
жесткий диск) и(или) перейти к печати отчета (см. Печать отчета). 
  

Предварительный просмотр и печать отчета 
Перед  выводом  отчета  на  печать  следует  выполнить  предварительный  просмотр.  Для 
этого на панели меню выбрать команду Файл->Предварительный просмотр
Если отчет не помещается на странице, то можно: 
•  изменить размер шрифта командой Настройки->Размер шрифта
•  изменить  ориентацию  бумаги  (книжная  или  альбомная) - команда  Файл-
>Параметры страницы
•  изменить  параметры  страницы  (размеры  полей)) - команда  Файл-
>Параметры страницы
Для вывода отчета на принтер следует нажать кнопку  на панели управления или задать 
команду Файл->Печать или нажать комбинацию клавиш Ctrl+P


Сохранение данных на жесткий диск 
Считанные  из  корректора  данные  можно  сохранить  на  жесткий  диск  компьютера. 
Поддерживаются следующие форматы файлов: 
•  xls - файл MS Excel. Файл представляет собой сформированный отчет; 
•  gbf - двоичные  файлы  Гелиос.  На  основе  сохраненных  данных  можно 
сформировать  отчеты  по  всем  архивам  и  отобразить  настройки  газового 
корректора; 
  
Для сохранения данных на жесткий диск необходимо
•  Прочитать данные из корректора; 
•  Выбрать  команду  Файл-Сохранить  на  панели  меню  или  нажать  кнопку 
на панели управления или нажать комбинацию клавиш Ctrl+S
•  Ввести название файла и выбрать его формат. 


Чтение данных с жесткого диска 
Сохраненные ранее данные из корректора можно прочитать с жесткого диска компьютера 
для  формирования  отчетов  о  газопотреблении.  Поддерживаются  следующие  форматы 
файлов: 
•  xls - файл MS Excel
•  gbf - двоичные файлы Гелиос; 
  
Для чтения данных с жесткого диска необходимо : 
•  Выбрать  команду  Файл-Открыть  на  панели  меню  или  нажать  кнопку 
на панели управления или нажать комбинацию клавиш Ctrl+O
•  В раскрывшемся окне выбрать необходимый файл; 
•  Перейти  к  формированию  отчета  (если  открыт  двоичный  файл ) (см. 
Формирование отчета) или печати (если считан xls файл) (см. Печать отчета). 
 


Похожие:

Описание программы Гелиос  iconБурбо Лиз, «Пять травм, которые мешают быть самим собой»: «София», ид «Гелиос»; Киев; 2003

Описание программы Гелиос  iconПояснительная записка 33 Аналитическое обоснование программы 35 Раздел I. Предназначение школы. Приоритетные направления в работе школы, цели и средства 37 Раздел II. Описание «модели»
Целевое назначение общеобразовательной программы начального общего образования: 42
Описание программы Гелиос  iconРуководство для версии 6 
Описание программы   2 
Описание программы Гелиос  iconИнструкция по работе с программой Arteferro cad 4 
Описание программы   3 
Описание программы Гелиос  iconДрунвапо Мепьхиседек. Древняя Тайна Цветка Жизни. Том 2
Издательство «София») isbn 5-344-00087-1 (Издательский Дом «Гелиос») isbn 1-891824-21-х (Light Technology Publishing)
Описание программы Гелиос  iconКраткое описание программы проведения мероприятий Первого Международного слета учителей г. Ялта – 2012
Размещение в отеле, выдача программы мероприятий и раздаточных материалов буклет с кратким описанием всех презентаций своего заезда,...
Описание программы Гелиос  iconНазвание программы
Твики реестра подробное описание + очень полезная система восстановления Windows
Описание программы Гелиос  iconРуническое учение
Руническое учение: Введение в эзотерическую рунологию / Пер с англ. — М.: София, Гелиос, 2002. — 320 с
Описание программы Гелиос  iconОбщее описание Описание сенсоров Описание работы таймера Управление Безопасность Предупреждения Использование посуды Уход и чистка Установка
...
Описание программы Гелиос  icon  европа НА ладони – описание экскурсионной программы зима 2009-10 
Во  время  экскурсии  вы  пройдете  по  историческому  центру  столицы  Чехии  от  Пражского  Града, 
Разместите кнопку на своём сайте:
kak.znate.ru


База данных защищена авторским правом ©kak.znate.ru 2012
обратиться к администрации
KakZnate
Главная страница